Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, Ed, biapar, Willr, Ingo, swaiba

Error message when trying to access cms login page

Go to End

4 Posts   1299 Views


Community Member, 63 Posts

25 May 2011 at 8:55am

Hi everyone!

I´ve just installed SS 2.4.5 on my live-webserver (for the first time - been developing on mamp). The installation went smoothly without any problems. I followed the step-by-step documentary....after adding my custom content (theme, some codes and modules) I imported the database to mySQL and ran a dev/build.
Website is showing (not quite as it should look like but nothing I couldn´t fix) BUT when I try to access the CMS login (admin) page to log in I get the following error (included in a seperate .txt file due to it´s length.
Does anyone have a solution or do I have to reinstall? If so, what could probably have caused this error so I don´t make the same mistake again? Obviously must have something to do with my custom content (which worked fine on MAMP)....
appreciating any help

kind regards

Attached Files

Forum Moderator, 5523 Posts

25 May 2011 at 5:32pm

Versioned::get_version: Couldn't get SiteTree.1

For some reason the code is trying to get a SiteTree versioned object that doesn't exist. From looking at the backtrace is originates from a template file so it could be a caching issue so try visiting admin/?flush=all rather than admin/ to flush that out.

If you have just installed SS, then I suggest dropping or emptying the database and running dev/build again and see if you have any issues. Make sure dev/build is successful by scrolling all the way to the bottom of the page.


Community Member, 63 Posts

26 May 2011 at 12:27am

thanks Willr!!
flush all did it!! However now it won´t let me login with my mail and password. I´m pretty sure it´s correct but is there a way to check the login data other than to reinstall??

many thanks in advance!!


Community Member, 63 Posts

26 May 2011 at 2:30am

Nevermind...reinstalled and tried again. Works fine until i import my own database. After that the login page gives me the same error as before except that flush all didn´t work this time :-(
So I emptied my database (as you suggested) and did a dev build. Again all went back to normal. Login worked and all. But re-importing my database doesn´t work anymore due to the following cause:



-- database: `rs_reisen`
-- --------------------------------------------------------
-- table structure for table `ArticlePage`
CREATE TABLE `ArticlePage` (
`Date` date DEFAULT NULL ,
`Author` mediumtext,

MySQL reports: Documentation
#1050 - Table 'ArticlePage' already exists

so is there anything wrong with my database? although it says "articlepage" already exists the database shows zero tables in myphp