Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

DataObjectManager Module /

Discuss the DataObjectManager module, and the related ImageGallery module.

Moderators: martimiz, UncleCheese, Sean, Ed, biapar, Willr, Ingo, swaiba

DataObject_Manager stopped working

Go to End

14 Posts   2319 Views


Forum Moderator, 4102 Posts

28 February 2010 at 1:46pm

Well, that's good. That's the ID of the file that was uploaded. If it got that far, that means there were no errors.

I'm not sure why the file isn't being stored on your sever. Permissions, maybe?


Community Member, 31 Posts

28 February 2010 at 2:01pm

Please check my latest reply
I noticed that
are both empty...hint?

my assets folder permission is 777


Community Member, 12 Posts

6 March 2010 at 11:24am

I'm having this issue too. Mine happened after I moved to a new server. I tried setting assets to 777, but that didn't work for me either.


Community Member, 31 Posts

7 March 2010 at 8:03am

Hi Bellafaith,
I could solve the issue by asking my host to remove the value of
upload_tmp_dir from php.ini.
I had problems using phpmyadmin's import utility.
After searching the net for an answer I found that the above setting should point to a directory on the server.
I asked my host to set a value and the import utility started working but obviously broke swfupload.
I'm not saying that the same appllies to you but worth checking.
You could also compare both of your server settings using php info() and see what is different.


Community Member, 12 Posts

14 March 2010 at 11:44am

Hi Cem,
Thanks for the advice. I compared the phpinfo() for both servers, but couldn't find anything different that was causing the problem. The server where upload is working doesn't have a value set for upload_tmp_dir in php.ini, but I set it on the non-working server to see if that fixed it, it didn't. I even tried a fresh install of silverstripe with basic blackcandy theme and no modules, and I get the error message when uploading that there's no temporary folder and to set upload_tmp_dir in php.ini (but it is set in php.ini). So it is looking like this is a server issue even though I spent an hour on the phone with the client's host who couldn't tell me or help me with anything that I didn't already know other than them saying it can't be a server issue.


Community Member, 12 Posts

24 June 2010 at 4:22am

Edited: 24/06/2010 4:23am

My problem was the upload_tmp_dir value. What I was trying [and what the hosting company was telling me to use] was not the correct path. I finally figured out the correct path and posted my solution here.

Go to Top