Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

We're retiring the forums!

The SilverStripe forums have passed their heyday. They'll stick around, but will be read only. We'd encourage you to get involved in the community via the following channels instead:

DataObjectManager Module /

Discuss the DataObjectManager module, and the related ImageGallery module.

Moderators: martimiz, UncleCheese, Sean, Ed, biapar, Willr, Ingo, swaiba

Uploadify HTTP Error

Go to End

80 Posts   30604 Views


Forum Moderator, 4102 Posts

22 June 2011 at 3:29am


Si l'erreur que tu reçois est bien 302, la désactivation d'authentification va résoudre ton problème, mais si l'erreur HTTP est 404 ou 500, tu as des autres problèmes et je te conseille d'utiliser un outil comme Charles ( pour obtenir le texte de l'erreur exacte.

Bonne chance !

SilverStripe tips, tutorials, screencasts and more:


Community Member, 26 Posts

3 August 2011 at 9:44pm

I had the same issue with Uploadify throwing a "HTTP error" when uploading files in the CMS (Files & Images Tab).

The following solution solved my Problem:

1. Upgrading Uploadify and DataObjectManager to the latest revisions from github (
2. Doing a /dev/build/?flush=1
3. Turnning off mod_security by adding this to the .htacces of the Silverstripe root (/.htaccess):

# Turn off mod_security to prevent HTTP errors on Uploadify Module
SecFilterEngine Off

Terry Apodaca

Community Member, 112 Posts

4 August 2011 at 2:58am

@silverseba, that would work perfectly and does as long as your server is set up the same...but some of us have mod_security2 (version 2) which is suppose to me much better. Mod Sec 2 doesn't allow you to control (turn off) it from the htaccess file or any other config file.

I have a few other servers to move sites to, but if you have a client that has their own hosting and/or you have no control, then you are stuck with what ever version the host the solution needs to also find a way to work around mod_security2


Community Member, 40 Posts

5 August 2011 at 1:33pm


I'm receiving the HTTP ERROR in the Files & Images tab on 1 installation of Silverstripe. It's hosted on a different server to all our other installations (Westnet).

The error only appears when I try to upload a PDF. It allows me to upload a JPG.

I tried SecFilterEngine Off but received a 500 internal server error.

I also tried UploadifyField::disable_authentication() but also got a 500 internal server error.

I'm running latest version of everything.

Anyone have any ideas?



Community Member, 26 Posts

5 August 2011 at 6:51pm

If you get an error 500 when setting SecFilterEngine Off in your .htaccess file, then your webhost doesn´t allow to change the mod_security setting from a .htaccess file.

The best (but not easiest) way would be to contact your webhost and ask them to change the setting for you. Or to switch from a shared to a managed server, where you can change the settings yourself.


Community Member, 13 Posts

13 August 2011 at 2:20am

Hello guys,
I also receive a HTTP 500 error, wether I'm uploading via Files & Images or the image gallery module. As of now i have the latest releases vom Github on silverstripe 2.4.5. The files are uploaded successfully and appear in their destinated folder after I refresh the page. In the case of the image gallery they aren't added to the album although they reside in the albums folder.
The response sais the following:

GET http://localhost/ss245_new/admin/EditForm/field/GalleryItems/UploadifyForm/field/UploadedFiles/refresh?SecurityID=c509281361e2af655cdd81bbf8b199fbd0d1d961&ctf[GalleryItems][start]=0&ctf[GalleryItems][per_page]=10&ctf[GalleryItems][showall]=0&ctf[GalleryItems][sort]=SortOrder&ctf[GalleryItems][sort_dir]=&ctf[GalleryItems][search]=&ctf[GalleryItems][filter]=AlbumID_4&ctf[GalleryItems][view]=grid&ctf[GalleryItems][imagesize]=100&FileIDs=%EF%BB%BF300 500 (Error: "Couldn't run query:  SELECT "File"."ClassName", "File"."Created", "File"."LastEdited", "File"."Name", "File"."Title", "File"."Filename", "File"."Content", "File"."Sort", "File"."SortOrder", "File"."ParentID", "File"."OwnerID", "File"."ID", CASE WHEN "File"."ClassName" IS NOT NULL THEN "File"."ClassName" ELSE 'File' END AS "RecordClassName"  FROM "File"  WHERE (`File`.ID IN (300))  ORDER BY "SortOrder" ASC   Unknown column '300' in 'where clause'" at line 525 of D:\xampp\htdocs\ss245_new\sapphire\core\model\MySQLDatabase.php)

Any clues what causes this problems?


Forum Moderator, 4102 Posts

13 August 2011 at 5:32am

This is perfectly valid SQL. (`File`.ID IN (300))

I'm not sure why it's complaining about that. Is this MySQL?


Community Member, 13 Posts

13 August 2011 at 6:57am

Edited: 13/08/2011 6:30pm

yeah i know its valid. I'm using MySQL 5.5.14.

[EDIT] Some further information. I've copied the query to the commandline client and I have there appears an ? before the numerical ID. Could this be some "invisible" unicode character? Loading into a hex editor shows the following character codes in front of the ID: ef bb bf